librmagick-ruby_2.13.0-2 for Ubuntu Lucid 10.04

I just upgraded to the newest Kubuntu Lucid 10.04 and here we go the first regression, I can’t compile anymore “my” software.
Here is the error:

This installation of RMagick was configured with ImageMagick 6.5.5 but ImageMagick 6.5.7-8 is in use.

So I immediately searched through Launchpad and found that there is already a bug report about that: Bug #518122
That refers to an already fixed bug on Debian bug tracker: Bug #557778

So I just grabbed the Debian testing sources for librmagick-ruby_2.13.0-2 lowered one dependencies and finally compiled under my Lucid aaaaaand here we go, the zip package containing all debs you need to fix this issue! ENJOY!!!

WARNING: Use this at your own RISK, I’m not responsible for any damages!

librmagick-ruby_2.13.0-2_i386.zip for Ubuntu 10.04 32 bit


4 thoughts on “librmagick-ruby_2.13.0-2 for Ubuntu Lucid 10.04”

  1. I have been testing it for over a month now… again and again… I confess I had to test this also (I run Redmine on Rails on my server – which is now dead cause of this) but amongst the three thousand tests I did run, this has escaped me :-/

    I have tried your fix with the debian patch, and it solved my issue šŸ˜‰ Great job… I am not sure if that is 100% compatible with everything else which might use this lib, but redmine is a O.K.

    Do you know what needs to be done to get this patch into a release .deb file in the repository? at least a backport !

  2. Fabio Leitao:
    I tried to compile the Ubuntu package with only the patch needed to fix the issue, but didn’t work for me, not sure what went wrong, so I decided to compile directly newer version.

Leave a Reply

Your email address will not be published. Required fields are marked *